World editor Lagging

Discussion in 'World Editor' started by buzzinggamer, May 15, 2022.

  1. buzzinggamer

    buzzinggamer
    Expand Collapse

    Joined:
    Mar 13, 2021
    Messages:
    15
    Need some help working out how to stop my world editor from legging.
    My item list is lagging my game but i no idea why.
    when i have the item list down to 19 the game runs fine but cant see what the items look like now so when i put it back to 100 the game just slows right down where its is impossible to use. it happens every so often but i have no idea why.
    In task manager nothing is over 50% so i dont get why its struggling
    would love some help on this its sending me crazy.
     

    Attached Files:

    • 170f58060e9e330ba5798636dc897222.png
    • 1c5aec783e7e748151fa06ede9db6488.png
    #1 buzzinggamer, May 15, 2022
    Last edited: May 15, 2022
  2. Mopman93

    Mopman93
    Expand Collapse
    BeamNG Team

    Joined:
    Jun 24, 2017
    Messages:
    91
    Does this low framerate stay for long? At the beginning the asset browser is generating the thumbnails, so the fps might go down, but that should only happen once. Does it get fixed when you scroll all the way down and up again?
     
  3. buzzinggamer

    buzzinggamer
    Expand Collapse

    Joined:
    Mar 13, 2021
    Messages:
    15
    It used to be like that when i open it up and ill just leave it for a second for it to sort its self out but now when i open it and got to the same folder ive left it open and scrolled down a couple times over 10 minutes and the frame stays at 1 to 5 some times 15 not no more than 15 and ive dont everything i can to help it load but scrolling down and letting it do its things but the only thing that works is putting the item list down to 19 but then i cant see the objects
     
  4. buzzinggamer

    buzzinggamer
    Expand Collapse

    Joined:
    Mar 13, 2021
    Messages:
    15
    Just found out it seems to be something to do with the pictures, when i have it at 19 theirs no pictures and runs perfect but when i get pictures to show the frames drop.

    Dont mind the 30 frames that just because i tab out to screen shot its goes up to 97 fps when theirs no pictures

    even in the last picture their nothing much to load but when the i move the item number higher for pictures the frames are none existent.
     

    Attached Files:

    • 1d7933dadc0e1058477a5eac6b875c7f.png
    • 717501ae38292ccd3a6aabb1f6cab289.png
    • 35eddb9e43c4f0d73e62e74a637e51c0.jpg
    #4 buzzinggamer, May 16, 2022
    Last edited: May 16, 2022
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice