1. Stuck or having problems creating your mod?
  2. GPU Fatal Error? Intel HD Graphics 620/630 Crashes? Help us solve them!
    Dismiss Notice

Solved Problems with roadmarkings decal roads

Discussion in 'Mod Support' started by RetrO_TyT, Dec 10, 2018.

Tags:
  1. RetrO_TyT

    RetrO_TyT
    Expand Collapse

    Joined:
    Mar 15, 2017
    Messages:
    342
    Hello. I'm having trouble with the markings. All decalroads are taken from WCUSA. But just for the WC roadmarkings, all is well and it is over the road. I have it hiding under the road. Any ideas?

    MY:
    screenshot_2018-12-10_21-42-18.png
    WCUSA:
    screenshot_2018-12-10_21-50-42.png
     
  2. thomatoes50

    thomatoes50
    Expand Collapse
    Staff Member

    Joined:
    Jan 31, 2013
    Messages:
    647
    Use the property `renderPriority` to "sort" the decals
    The closer to 0 the high the priority will be
     
  3. krallopian

    krallopian
    Expand Collapse
    Staff Member

    Joined:
    Dec 5, 2013
    Messages:
    664
    Word of advice - keep the number higher than lower. For instance I build my first big road system, then learned about placing lines over top and other details, and I had my roads all set to 0. So I had to up them all again, and then AGAIN when I added more detail - If I had just left them alone or bumped them up in the render order that would have saved me a ton.

    Road should be render priority 30, then everything that goes on top can be 29..28...27...26... etc. Sometimes I'd just hold the down area at 0 and it'd count to -20 and when I let go it would render on top again, but only sometimes and only certain textures.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice