1. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    Solutions and more information may already be available.

Problems with new update

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by IMAMAZING123, Apr 9, 2020.

  1. IMAMAZING123

    IMAMAZING123
    Expand Collapse

    Joined:
    Apr 9, 2020
    Messages:
    1
    I'm wondering if anyone is having the same problem I'm having with the new update of Beamng drive and if anyone would know how to fix it. Every time I start up beamng drive it takes multiple seconds to load and the says an error occurred while updating beamng Drive. So I'm just wondering f anyone else is having this problem.
     
  2. seanzilla

    seanzilla
    Expand Collapse

    Joined:
    Apr 9, 2020
    Messages:
    7
    You're not alone. I've noticed more vehicle sway while driving and an issue with camera rotation. I've already checked my mappings and deadzones since I'm using a 360 controller and they don't seem out of wack or anything. ill just be driving along and all the sudden the camera goes all the way up.
     
  3. vmlinuz

    vmlinuz
    Expand Collapse

    Joined:
    Mar 2, 2014
    Messages:
    1,696
    Maybe you need a new controller?
    --- Post updated ---
    That sounds like an issue with Steam. Try fully reinstalling the game?
     
    • Agree Agree x 1
  4. seanzilla

    seanzilla
    Expand Collapse

    Joined:
    Apr 9, 2020
    Messages:
    7
    That was one of my guesses but im going to map it to another function and test it. Its just odd that I never had any issues until yesterday...
     
  5. ∇ RIC3FIELD ▶

    ∇ RIC3FIELD ▶
    Expand Collapse

    Joined:
    Feb 22, 2020
    Messages:
    16
  6. Nadeox1

    Nadeox1
    Expand Collapse
    Administrator
    BeamNG Team

    Joined:
    Aug 5, 2012
    Messages:
    14,566
    If the message is similar to the one above me:

    Check that your Antivirus, or similar, is not blocking or deleting files at random from the game. Chance is that it's picking a false-positive and deleting game files.
    Add the game to its exclusion list if necessary.

    Then please follow the instructions in here to let Steam attempt to fix it:
    https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

    If the issue still persists, please perform a Clean Install instead:
    https://wiki.beamng.com/BeamNG_FAQ#How_do_I_perform_a_clean_reinstall.3F
    Follow the steps carefully without skipping any of them.
     
  7. aCharmlessMan

    aCharmlessMan
    Expand Collapse

    Joined:
    Nov 21, 2015
    Messages:
    53
    I'm suddenly having problems this morning getting the game to run on Steam. The update initially downloaded fine and I had no issues, now it's refusing to run. I had a couple of error messages coming up on Steam one to do with the incorrect platform and another to do with an exe file. Having tried a few fixes that Steam suggested that haven't worked I'm in the process of trying to do a clean reinstall but it just keeps installing over and over again.
     
  8. Quarter58

    Quarter58
    Expand Collapse

    Joined:
    Nov 18, 2019
    Messages:
    1
    When i click spawn on every map i have (including the ones that are mods) it just sends me back to the main menu
     
  9. Nadeox1

    Nadeox1
    Expand Collapse
    Administrator
    BeamNG Team

    Joined:
    Aug 5, 2012
    Messages:
    14,566
    You need to check without mods, or better in Safe Mode (Launcher > Support Tools).
    Broken mods can cause such issues.

    As a good rule of thumb, you should always check the mods after an update.
     
  10. aCharmlessMan

    aCharmlessMan
    Expand Collapse

    Joined:
    Nov 21, 2015
    Messages:
    53
    An update on my last post, I have removed McAfee from my PC and that seems to have solved the problems. Looks like the subscription had expired anyway (came with my computer) so I am going to use Windows Defender plus Malwarebytes.
     
  11. asier

    asier
    Expand Collapse

    Joined:
    Jul 11, 2016
    Messages:
    12
    Hi. Today i tried to play this game and i had those 2 problems:

    20200410_144215.jpg 20200410_144152.jpg
    I tried to reinstall clean the cache verificate the objetcs and delete everything and notching. I can't play. Can you send me other solutions. Thank you so much
     
  12. TOCG

    TOCG
    Expand Collapse

    Joined:
    Apr 10, 2020
    Messages:
    1
    The same problem is happening to me.
     
  13. Nadeox1

    Nadeox1
    Expand Collapse
    Administrator
    BeamNG Team

    Joined:
    Aug 5, 2012
    Messages:
    14,566
    See post #6, your issue is the same.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice