1. Intel iGPU (6xx series) crashes
    Fixed drivers available!
    Instructions here

    Dismiss Notice
  2. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    0.20 Bug Reporting thread
    Solutions and more information may already be available.

BeamNG.drive UI extremely slow.

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by LionsTheBoss, Apr 6, 2018.

  1. LionsTheBoss

    LionsTheBoss
    Expand Collapse

    Joined:
    Jul 12, 2016
    Messages:
    51
    I've searched the forums, and haven't found a definitive solution for my situation. I can run the game 50-60 fps at 4K, but when I open the UI or change something on a car it takes forever to open new menus and change things.

    I have a GTX 1080 a I7-7700K no shortage in power...?
     
    • Agree Agree x 1
  2. PriusRepellent

    PriusRepellent
    Expand Collapse

    Joined:
    Mar 19, 2018
    Messages:
    307
    I have the same issue with a Fury X, and a Core i7 4790k
     
  3. Nathan24™

    Nathan24™
    Expand Collapse
    Banned

    Joined:
    Apr 18, 2017
    Messages:
    2,673
    Wrong sub-forum?
     
  4. JonasTMT

    JonasTMT
    Expand Collapse

    Joined:
    Sep 5, 2016
    Messages:
    327
    How many mods do you have? More mods equals longer waiting times. (Because more thing have to be loaded in.)
     
  5. Nadeox1

    Nadeox1
    Expand Collapse
    Administrator
    BeamNG Team

    Joined:
    Aug 5, 2012
    Messages:
    14,724
    ^

    Also, at 4K, you want to not disable the UI resolution limiter. The UI is not meant to run at such high resolution, should be kept at maximum 1080p (the setting is Options > Graphics)
     
    • Informative Informative x 1
  6. Nivracer

    Nivracer
    Expand Collapse

    Joined:
    Jan 23, 2014
    Messages:
    352
    I have this problem too, the game runs at 25-40 fps and the UI when changing parts or adjusting the setup on the car runs at 1-2 fps, with or without mods.
     
  7. Achitori

    Achitori
    Expand Collapse

    Joined:
    Jul 22, 2016
    Messages:
    7
    This been a problem since the engine sound update. It got worse with this update. Even if i pause the time, it is slow. The game runs at 60fps, only the whole ui is super slow
     
    • Agree Agree x 1
  8. itsjustspacy

    itsjustspacy
    Expand Collapse

    Joined:
    Aug 8, 2013
    Messages:
    2
    I agree even at 720p UI res it gets extremely slow. I have to manage this by pausing the game to change the major parts of the vehicle to get most of the loading under control instead of loading the car after each modification.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice