Added parts showing up as empty on menu?

Discussion in 'Content Creation' started by LionsTheBoss, Jul 10, 2020.

  1. LionsTheBoss

    LionsTheBoss
    Expand Collapse

    Joined:
    Jul 12, 2016
    Messages:
    54
    I was wondering if there's a way to have the engine load up with certain parts pre-selected like the stock engines.

    Screenshot23_LI.jpg
     
  2. _Diamond_Coal_

    _Diamond_Coal_
    Expand Collapse

    Joined:
    Apr 5, 2019
    Messages:
    515
    You need to add name of your part in jbeam
    Inkednotepad_3el6y1MfWN_LI.jpg
    "default" means part that wold be set as default in slot
     
  3. LionsTheBoss

    LionsTheBoss
    Expand Collapse

    Joined:
    Jul 12, 2016
    Messages:
    54
    So in "default part" I put the name of the parts jbeam? For instance, "subaru_transmission_6M_sti_04"? I'm still a little confused, a more in depth explanation would be great. Thank you for your help
     
  4. ossy21

    ossy21
    Expand Collapse

    Joined:
    Jun 13, 2020
    Messages:
    6
    So the way you have it setup, your engine has a slot named "transmission". When you set that slot up in the engine jbeam, your first set of brackets is the slot type (i.e. transmission), the second set of brackets defines the default jbeam to load. Leaving it blank " " will load nothing, you'll want to put the "subaru_transmission_6M_sti_04" in there as the default to automatically load. The third set of brackets is the description that will actually show up in beamNG drop down list, which you have as "transmission".
     
    • Agree Agree x 1
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice