Solved Vehicle configuration mod - only shows up in save & load list

Discussion in 'Mod Support' started by Jeppe Ladefoged, May 24, 2022.

  1. Jeppe Ladefoged

    Jeppe Ladefoged
    Expand Collapse

    Joined:
    Dec 1, 2020
    Messages:
    4
    I'm trying to make a vehicle configuration mod for my BeamMP server.
    I got the .pc and .jpg files in a zip and they show up in the game so the directory structure is correct.
    But they only show up in the "Save & load" list and not in the nice vehicle selection window with the thumbnails.
    What am I missing?
     
  2. Chuck_Norris_

    Chuck_Norris_
    Expand Collapse
    BeanNG
    BeamNG Team

    Joined:
    Aug 10, 2013
    Messages:
    113
    Please make sure that “show custom configurations” is enabled in gameplay settings as sometimes it can be unticked & won't show your configs in the menu.
     
  3. Jeppe Ladefoged

    Jeppe Ladefoged
    Expand Collapse

    Joined:
    Dec 1, 2020
    Messages:
    4
    I'm aware of the setting and that does indeed work, but I do not expect an average BeamMP player to figure that out.
    Is this is the only way?
     
  4. DaddelZeit

    DaddelZeit
    Expand Collapse

    Joined:
    Jul 17, 2019
    Messages:
    3,084
    You need an *_info.json.
    Check out vanilla cars: those have a .pc, .png/.jpg and an _info.json for each config.
     
  5. Jeppe Ladefoged

    Jeppe Ladefoged
    Expand Collapse

    Joined:
    Dec 1, 2020
    Messages:
    4
  6. Jeppe Ladefoged

    Jeppe Ladefoged
    Expand Collapse

    Joined:
    Dec 1, 2020
    Messages:
    4
    It works. Thanks :)
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice