1. Issues with the game?
    Check the Known Issues list before reporting!

    Dismiss Notice
  2. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    0.25 Bug Reporting thread
    Solutions and more information may already be available.

"Tab" key won't advance POV to next vehicle

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by B3_Burner, Feb 14, 2022.

  1. B3_Burner

    B3_Burner
    Expand Collapse

    Joined:
    Mar 13, 2019
    Messages:
    397
    Hi, it's been a while since I've been here, I see there's been lots of changes. If this has already been discussed or posted in the "Known Issues", section I'll apologize in advance. I searched and didn't find any information on this.

    When I'm in AI mode, OR replaying a recording that had AI vehicles in it, I cannot use Tab to advance to the point of view of the next vehicle, or Ctrl + Tab to regress to the POV of the previous vehicle.

    I'm not sure if this is a replay issue or an AI issue (I'm guessing the latter), but I also ran an integrity test and it says I'm missing one file, (which I red-fonted below). Here was the report I got:

    If you think the missing file is causing the tab button not to work, how do I get that file back?
    Thank you in advance for your time.
    -----------------------------------------------------

    0.00203|D|logging| -- Log started - v 0.24.1.2 - x86 - build 13546 - 2022-02-14 -- 14:30:22 -----
    0.00205|D|logging| -- buildbot build 13546 on winbuildbot3 - 27/01/2022 - 16:25:26
    0.00205|D|logging| -- Log Format: Time since startup | Message level: D(ebug), I(nfo), W(arning), E(rror), A(lways) | Message
    0.00254|I|WinMain| launcher command line [1]: "F:\SteamLibrary\steamapps\common\BeamNG.drive\BeamNG.drive.exe"
    0.00255|D|baseFS| gameroot = 'F:\SteamLibrary\steamapps\common\BeamNG.drive\'
    0.00255|D|baseFS| userpath = 'F:\Documents\BeamNG.drive\0.24\' , Reason = Win32 registry
    0.00267|I|bng_platform_version| Microsoft Windows 10 2009 (v10.0) (build 19044), 64-bit
    0.00468|E|bng::i18n::loadLanguage| unable load language: /locales/en-US.json
    0.00479|E|bng::i18n::setLanguage| fallback translation files not found!!
    0.00484|I|data_migration| No migration necessary
    0.08366|I|gpu_driver| Nvidia Driver version = 496.76 (49676), branch = 'r496_65'
    124.44903|I|clearOldCaches| Start clearing old caches
    124.81741|I|clearOldCaches| Deleted C:\Users\John\Documents\BeamNG.drive\cache.0.20.2.0
    130.96846|I|clearOldCaches| Deleted F:\Documents\BeamNG.drive\0.22/temp
    154.18432|I|clearOldCaches| Deleted F:\Documents\BeamNG.drive\0.23/temp
    160.10422|I|clearOldCaches| Deleted F:\Documents\BeamNG.drive\0.24/temp
    172.83217|D|verifyHash| Starting integrity checking ...
    172.85121|D|verifyHash| Read 3140 hash entries, checking and hashing them now...
    354.39602|I|verifyHash| Hashed all 3140 files - 3.837 GB data in 181.55 seconds
    354.39602|I|verifyHash| - 17.30 files / second
    354.39602|I|verifyHash| - 157.01 MB / second
    354.49685|I|verifyHash| === Differences ===
    354.49689|I|verifyHash| f:/steamlibrary/steamapps/common/beamng.drive/replays/scriptai/tracks/testfinish2.track.json: missing
    354.49690|I|verifyHash| === Differences statistics ===
    354.49690|I|verifyHash| missing : 1 files
     
  2. Joobles

    Joobles
    Expand Collapse

    Joined:
    Sep 30, 2017
    Messages:
    432
    There's a setting that allows you to switch between AI cars, I think it's in gameplay?
     
    • Like Like x 1
    • Agree Agree x 1
  3. B3_Burner

    B3_Burner
    Expand Collapse

    Joined:
    Mar 13, 2019
    Messages:
    397
    Thank you. Yes, I believe I found that. That's what's set to TAB.
    So to update, this is what I've discovered thus far:

    1. I uninstalled and reinstalled the game, in order to try to gain back that missing file. As far as I can tell, it didn't work. But it may be a "red herring" of sorts, and has nothing to do with the issue I've been experiencing.

    2. When I call on AI cars and I'm playing with them live, I cannot use TAB to switch POV between them. I'm now beginning to think that that's normal, and that so many months have gone by since I last played this game, that I had forgotten this fact.

    3. When I record with AI cars and go to play it back, sometimes TAB works, but sometimes it doesn't. I haven't quite narrowed down the variables that introduce this problem as of yet.

    4. If I introduce cars manually using the "new vehicle" feature in the "Vehicles" section, then I can TAB between cars and switch POV and control of the car, with no issues at all.

    As I said above, it may be that I haven't played the game in so long, I forget what the TAB feature can & cannot do.
     
  4. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    6,792
    It shouldn't work on traffic, but should in replays, this is kinda weird
     
  5. B3_Burner

    B3_Burner
    Expand Collapse

    Joined:
    Mar 13, 2019
    Messages:
    397
    Okay, as I suspected it's been so long, I forgot it didn't work on live traffic.

    Replays, sometimes yes sometimes no.
    If I open the BeamNG.exe file from the main menu, it seems to work better than if I start using the BeamNG shortcut start icon directly related to Steam. Go figure. Now realize, the latter was created AFTER I reinstalled the game. And the .exe start file was what was left over before the uninstall/reinstall. That maybe has something to do with it. Best I can do at this point is continuing to monitor and be happy when it works right.
     
    #5 B3_Burner, Feb 16, 2022
    Last edited: Feb 16, 2022
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice