1. Issues with the game?
    Check the Known Issues list before reporting!

    Dismiss Notice
  2. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    0.25 Bug Reporting thread
    Solutions and more information may already be available.

[SOLVED] Engines randomly stop working (Sunburst and D-Series)

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by SuperNoob05, Feb 4, 2015.

  1. SuperNoob05

    SuperNoob05
    Expand Collapse

    Joined:
    Jan 4, 2015
    Messages:
    1,287
    When I drive around with on Bajarama with the Sunburst or the D-Series, their engines just randomly breake.
    This only happens with those two cars, and I don't know what causes it.

    BTW: I'm using the newest stable/experimental version (0.3.7.5)
     
    #1 SuperNoob05, Feb 4, 2015
    Last edited: Feb 5, 2015
  2. defib

    defib
    Expand Collapse

    Joined:
    Aug 6, 2013
    Messages:
    490
    Re: Enignes randomly stop working (Sunburst and D-Series)

    Well I think its because you may have landed a jump too hard, this kills the engine
     
  3. GeoTelnet111

    GeoTelnet111
    Expand Collapse

    Joined:
    Mar 7, 2013
    Messages:
    193
    Re: Enignes randomly stop working (Sunburst and D-Series)

    Well, I really like how I can finally kill the engine now after an impact. :p Instead of being able to actually drive the car after slamming into a wall at 100+ MPH. haha
     
  4. juju

    juju
    Expand Collapse

    Joined:
    Aug 5, 2012
    Messages:
    76
    Re: Enignes randomly stop working (Sunburst and D-Series)

    I'm having the same glitch on Bajarama, happened on GridMap too, but it was rare.
    Also It seems to be affecting the Covet too. This bug is known by the developers btw.

    It's not because you land hard, but you drive around and suddenly the engine stops.
     
  5. vladmir poopin

    vladmir poopin
    Expand Collapse
    Banned

    Joined:
    Mar 17, 2013
    Messages:
    844
    Re: Enignes randomly stop working (Sunburst and D-Series)

    i think its to do with the axels something i have noticed when jumpin the covet is that if a brake the front one the engine goes down to about 50 rpm and if put it in N it goes normal
     
  6. gabester

    gabester
    Expand Collapse
    Vehicle Director
    BeamNG Team

    Joined:
    Jun 6, 2012
    Messages:
    2,657
    Re: Enignes randomly stop working (Sunburst and D-Series)

    Does the check engine light come on? If so, you probably went underwater somewhere - I'm guessing Bajarama has an invisible, 0-drag body of water or something that's enough to trigger our water engine kill.
     
  7. Josh

    Josh
    Expand Collapse

    Joined:
    Jul 21, 2013
    Messages:
    1,082
    Re: Enignes randomly stop working (Sunburst and D-Series)

    This also happens to me playing on groove range desert CEL lights up engine dies when driving half way down the airstrip.
     
  8. SuperNoob05

    SuperNoob05
    Expand Collapse

    Joined:
    Jan 4, 2015
    Messages:
    1,287
    Re: Enignes randomly stop working (Sunburst and D-Series)

    Yeah, it does. The weird thing is that the D-Series Offroad instantly dies. I drive like maybe 20 metres with it, and then it just dies
    Some modded vehicles like the Audi Quattro do this aswell.

    I'm gonna try to get some footage of this, but NVidea Shadowplay doesn't seem to like this game very much. (atleast not on my PC)
    But I might get some footage with some other software.

    I'm gonna post a link to the video once it's uploaded.
     
  9. gabester

    gabester
    Expand Collapse
    Vehicle Director
    BeamNG Team

    Joined:
    Jun 6, 2012
    Messages:
    2,657
    Re: Enignes randomly stop working (Sunburst and D-Series)

    The only cause of the check engine light would be going underwater. That's the map having a phantom body of water somewhere, not a bug with the vehicle.
     
  10. SuperNoob05

    SuperNoob05
    Expand Collapse

    Joined:
    Jan 4, 2015
    Messages:
    1,287
    Re: Enignes randomly stop working (Sunburst and D-Series)

    Is there a way to fix that? If so, could you please tell me how, (if you've got the time to) because it's quite annoying.
     
  11. gabester

    gabester
    Expand Collapse
    Vehicle Director
    BeamNG Team

    Joined:
    Jun 6, 2012
    Messages:
    2,657
    Re: Enignes randomly stop working (Sunburst and D-Series)

    I don't know much about level editing, but see if you can find any bodies of water in the level editor (F11) and delete them.
     
  12. Dummiesman

    Dummiesman
    Expand Collapse

    Joined:
    Sep 17, 2013
    Messages:
    4,634
    Re: Enignes randomly stop working (Sunburst and D-Series)

    Happens on a level without any water to the Sunburst rally/race configs. :(
     
  13. synsol

    synsol
    Expand Collapse
    QA Lead
    BeamNG Team

    Joined:
    Aug 4, 2013
    Messages:
    1,451
    Re: Enignes randomly stop working (Sunburst and D-Series)

    And with the RS version when i push the 3 hight rev at 160 km/h
     
    #13 synsol, Feb 5, 2015
    Last edited: Feb 5, 2015
  14. clayton8or

    clayton8or
    Expand Collapse

    Joined:
    Aug 26, 2013
    Messages:
    1,045
    Re: Enignes randomly stop working (Sunburst and D-Series)

    Seems like the engine is drowning itself...
     
  15. Dummiesman

    Dummiesman
    Expand Collapse

    Joined:
    Sep 17, 2013
    Messages:
    4,634
    Re: Enignes randomly stop working (Sunburst and D-Series)

    Engine suicide D:
     
  16. STICH666

    STICH666
    Expand Collapse

    Joined:
    Aug 4, 2013
    Messages:
    215
    Happens on Endless Highway and Insane Testing as well. No bodies of water present on solid land as far as I can see with the level editor. Seems to only happen on 3rd party maps.
     
  17. Toastno6

    Toastno6
    Expand Collapse

    Joined:
    Feb 15, 2015
    Messages:
    1
    This isn't solved, why is it marked as such? This glitch is driving me nuts. It happens on the Insane Testing track a ton with both third party and regular vehicles, particularly at the entracne to the rallycross section and even just when tooling around in the main area driving the Marshal. Anyone got a fix for this because it's a pain in the backside.
     
  18. randomshortguy

    randomshortguy
    Expand Collapse

    Joined:
    Aug 9, 2013
    Messages:
    1,574
    While the devs are right, it only happens on community maps, at least half of all community maps have a dead zone where any car that enters' engine will die instantaneously.

    I have poked through the .mis file and there are no ghost water bodies, I have even gone so far as to restructure Bajarama's mission assets in attempt to fix this. There's no errors of relevance in the log, so I really can't understand what's causing this.
     
  19. Miura

    Miura
    Expand Collapse

    Joined:
    Aug 5, 2012
    Messages:
    311
    Seems like it happens when the car goes below 0 z coordinate. The terrain in all of the mentioned maps starts at negative height. It's easy to test on Gridmap, it has most of the flat ground at 0 level, but the tunnel and small canyon are lower. That's where the engine stalls.

    It's not quite consistent. Sometimes I can drive in the valley, sometimes it floods the engine, always at 0 height.

    I tried raising the engine intake node a couple of meters higher. It still stalls when the center point of the car goes below 0, so it's not the intake.
     
    #19 Miura, Feb 17, 2015
    Last edited: Feb 17, 2015
  20. Aboroath

    Aboroath
    Expand Collapse

    Joined:
    Aug 25, 2013
    Messages:
    3,807
    Getting the engine kill on Grooved desert here. Also dies when trying to auger my way out of the spawn on Expressway. (D15).
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice