Released RK's Highly Customizable Engine (Now V8!) 3.3.0

The Most Customizable Engines on the Forum! Now even better!

  1. Zaffir

    Zaffir
    Expand Collapse

    Joined:
    Jan 21, 2017
    Messages:
    56
    @R4NKING I added a V10 to the Bruckell Bastion......
    Here are the Sound Configuration And Engine Data

    Its Not Complete.....I Only Copy/Pasted the necessary data so u can add it to all cars :)




    "mainEngine":{
    "torque":[
    ["rpm", "torque"]
    [0, 0],
    [700, 210],
    [1000, 310],
    [2000, 360],
    [3000, 405],
    [4000, 460],
    [5000, 500],
    [6000, 559],
    [6500, 568],
    [7000, 567],
    [7500, 562],
    [8000, 510],
    [8500, 360],
    [9000, 160],
    [10000, 0],
    ],

    "idleRPM":850,
    //max rpm physically capable of
    "maxRPM":8500,
    "revLimiterType": "soft",
    "inertia":0.11,
    "friction":12
    "dynamicFriction":0.024,
    //"burnEfficiency":0.39
    "burnEfficiency":[
    [0, 0.11],
    [0.05, 0.26],
    [0.4, 0.48],
    [0.7, 0.48],
    [1, 0.34],

    //exhaust
    "particulates":0.04
    "instantAfterFireCoef": 0.75,
    "sustainedAfterFireCoef": 0.70,

    //engine durability
    "cylinderWallTemperatureDamageThreshold":160,
    "headGasketDamageThreshold":1500000,
    "pistonRingDamageThreshold":1500000,
    "connectingRodDamageThreshold":2000000,

    "maxTorqueRating": 880,
    "maxOverTorqueDamage": 2000,







    "soundConfig": "soundConfig",
    "soundConfigExhaust": "soundConfigExhaust",

    "instantAfterFireSound": "event:>Vehicle>Afterfire>i4_01>single",
    "sustainedAfterFireSound": "event:>Vehicle>Afterfire>i4_01>multi",
    "shiftAfterFireSound": "event:>Vehicle>Afterfire>i4_01>shift",
    "instantAfterFireVolumeCoef": 5.5,
    "sustainedAfterFireVolumeCoef": 5.5,
    "shiftAfterFireVolumeCoef": 5.5,

    //starter motor
    "starterSample":"art/sound/gallardo_engine_startup",
    //"starterSampleExhaust":"event:>Engine>Starter>i4_2001_exh",
    "shutOffSampleEngine":"event:>Engine>Shutoff>i4_2001_eng",
    "shutOffSampleExhaust":"event:>Engine>Shutoff>i4_2001_exh",
    "starterVolume":1.50,
    "starterVolumeExhaust":1.0,
    "shutOffVolumeEngine":0.15,
    "shutOffVolumeExhaust":0.7,
    "starterThrottleKillTime":1.67,
    "idleRPMStartRate":0.8,
    "idleRPMStartCoef":4
    },
    "soundConfig": {
    "sampleName": "lam_huracan_15_engine",
    "mainGain": -10,
    "maxLoadMix": 1.5,
    "minLoadMix": 0,
    "onLoadGain":1,
    "offLoadGain":0.2,

    "eqLowGain": 10,
    "eqLowFreq": 450,
    "eqLowWidth": 0.3,

    "eqHighGain": 12,
    "eqHighFreq": 12000,
    "eqHighWidth": 0.3,

    "lowShelfGain":16,
    "lowShelfFreq":120,

    "highShelfGain":15,
    "highShelfFreq":11000,

    "fundamentalFrequencyCylinderCount":10,
    "eqFundamentalGain": 0
    },
    "soundConfigExhaust": {
    "sampleName": "lam_huracan_15_exhaust",
    "mainGain": -15,
    "maxLoadMix": 4.0,
    "minLoadMix": 0,
    "onLoadGain":0.7,
    "offLoadGain":0.2,

    "eqLowGain": 13,
    "eqLowFreq": 80,
    "eqLowWidth": 0.2,

    "eqHighGain": 8,
    "eqHighFreq": 10000,
    "eqHighWidth": 0.2,

    "fundamentalFrequencyCylinderCount":10,
    "eqFundamentalGain": 0
     
  2. blu3r4e

    blu3r4e
    Expand Collapse

    Joined:
    Dec 28, 2021
    Messages:
    12
    So I am having issues opening the mod. It doesn't show up at all when I have it opened
     
  3. Zaffir

    Zaffir
    Expand Collapse

    Joined:
    Jan 21, 2017
    Messages:
    56
    it gets disabled in mod manager.......you have to activate it everytime u open the game
     
    • Agree Agree x 1
  4. 520tutu2008

    520tutu2008
    Expand Collapse

    Joined:
    Dec 21, 2021
    Messages:
    8
    thanks for the fix btw is there a way you could add a v10 to the mod?
     
    #484 520tutu2008, Dec 28, 2021
    Last edited: Dec 28, 2021
  5. Zaffir

    Zaffir
    Expand Collapse

    Joined:
    Jan 21, 2017
    Messages:
    56
    Which car?
    Ill add it to a few cars (2-3 Cars) and ill upload the file over here.......Dont have enough time to add it to all cars......Sorry :)
     
  6. 520tutu2008

    520tutu2008
    Expand Collapse

    Joined:
    Dec 21, 2021
    Messages:
    8
    the d series, the pessima 1980, and the etk 800
     
  7. R4NKING

    R4NKING
    Expand Collapse

    Joined:
    Oct 14, 2016
    Messages:
    300
    You don't need to, i'm already working on the v10
    --- Post updated ---
    does it still get disabled trough modmanager even after the newest update?
     
  8. JamesM3E36

    JamesM3E36
    Expand Collapse

    Joined:
    Dec 11, 2019
    Messages:
    52
    At least for me it does get disabled every time
     
  9. R4NKING

    R4NKING
    Expand Collapse

    Joined:
    Oct 14, 2016
    Messages:
    300
    Okey i just wrote the support about it. I'm sorry but i'm trying my best
     
    • Like Like x 1
  10. TheZorg

    TheZorg
    Expand Collapse

    Joined:
    Jul 2, 2014
    Messages:
    8
    Same here, gets disabled every time. Don't worry though, it's a great mod and it only takes a couple of seconds to activate, it's worth it anyway
     
    • Agree Agree x 1
  11. 520tutu2008

    520tutu2008
    Expand Collapse

    Joined:
    Dec 21, 2021
    Messages:
    8
    and PLS FOR THE LOVE OF GOD ADD THE F4 ENGINE I WANT TO USE IT FOR MY SUNBURST so ya thanks for the fix again
     
  12. R4NKING

    R4NKING
    Expand Collapse

    Joined:
    Oct 14, 2016
    Messages:
    300
    just added the V10. I will beginn with the F4 now :)
    --- Post updated ---
    also, where did you get that huracan sound from? thats not from the stock game
    --- Post updated ---
    Is that okey? xD

     
    • Like Like x 1
  13. Mr_J

    Mr_J
    Expand Collapse

    Joined:
    Dec 28, 2021
    Messages:
    6
    So iv got this problem with this mod right, whenever i try to put on a supercharger and i apply it, it removes it by it self. Does anyone have a idea why it does this?
     
  14. blu3r4e

    blu3r4e
    Expand Collapse

    Joined:
    Dec 28, 2021
    Messages:
    12
    Uh I still have it activated and it still doesn't work
     
  15. R4NKING

    R4NKING
    Expand Collapse

    Joined:
    Oct 14, 2016
    Messages:
    300
    did you updated the mod?
    Do you have any other mods activated?
    --- Post updated ---
    Okay, be ready for a big content update soon :)
     
  16. blu3r4e

    blu3r4e
    Expand Collapse

    Joined:
    Dec 28, 2021
    Messages:
    12
    I tried to update the mod and it still doesn't work. What should I do
     
  17. R4NKING

    R4NKING
    Expand Collapse

    Joined:
    Oct 14, 2016
    Messages:
    300
    Do you have other mods installed? if yes deactivate all and only activate mine and try again
     
  18. blu3r4e

    blu3r4e
    Expand Collapse

    Joined:
    Dec 28, 2021
    Messages:
    12
    Yours is only activated and it still doesn't work
     
  19. SemKill

    SemKill
    Expand Collapse

    Joined:
    Feb 5, 2021
    Messages:
    28
    yes. for me too
     
  20. R4NKING

    R4NKING
    Expand Collapse

    Joined:
    Oct 14, 2016
    Messages:
    300
    On every car and every engine?
    can you send a log from the lua console (mine opens on the ยจ key, i have a swiss layout)
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice