1. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    0.23 Bug Reporting thread
    Solutions and more information may already be available.

Only 55% RAM, still lag

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by PolarBear123, Jan 11, 2020.

  1. PolarBear123

    PolarBear123
    Expand Collapse

    Joined:
    Dec 17, 2017
    Messages:
    40
    Hello guys, I have an ASUS TUF GAMING with i5 CPU 8th Gen, and 16 GB of RAM with an NVIDIA 1050 Ti Graphics card. When I do scenarios with many AI vehicles, or have traffic on the West Coast, my FPS drops down to 30. Any tips I could do? I have on High graphics and would prefer not to change. When I look in task manager, it seems like only 55% of all RAM is used. Is this normal?
    Thanks!
     
  2. Nadeox1

    Nadeox1
    Expand Collapse
    Santa's Spinning Cube
    BeamNG Team

    Joined:
    Aug 5, 2012
    Messages:
    14,653
    RAM usage is not a way to measure performance.
    It only tells how much memory the game is using, that's it.

    Performance depends more on your CPU and GPU.
    The more vehicles you add, the more things there are to be simulated, the more work your CPU has to do. 9 is quite a high amount of vehicles, and mainly very good CPUs can handle that. You might be hitting your CPU limits with that.
     
    • Agree Agree x 1
  3. PolarBear123

    PolarBear123
    Expand Collapse

    Joined:
    Dec 17, 2017
    Messages:
    40
    Thanks for the reply. So what would be considered a good CPU?
     
  4. GamerTag76

    GamerTag76
    Expand Collapse

    Joined:
    Apr 28, 2016
    Messages:
    65
    The more cores the CPU has, the more vehicles you can run without lag. I have a i7 9700KF with 8 cores and i can run 10 cars and still get over 60 fps. I believe the physics engine uses 1 core per vehicle spawned. So your best bet is to find a good CPU with at least 8 cores if you want to play with a lot of vehicles. 6 cores will do you fine if your on a budget.
     
    • Like Like x 1
  5. henryjhost

    henryjhost
    Expand Collapse

    Joined:
    Jan 1, 2018
    Messages:
    995
    Desktop 8th gen i5s (8400, 8500, 8600, 8600k) all have 6 cores so you should be fine if you are running 6 cars or less.
     
  6. den_chik

    den_chik
    Expand Collapse

    Joined:
    Dec 12, 2019
    Messages:
    789
    I think your GPU power is not enough too for many AI.
     
  7. WhatNot98

    WhatNot98
    Expand Collapse

    Joined:
    Dec 4, 2016
    Messages:
    286
    honestly i'd say that is the 1050 TI's fault. I have an RX 580 (GTX 1060 equivalent) and i would get low FPS too on high settings with lots of vehicles. Also, the fact that West Coast USA has the worst optimization of any vanilla BeamNG.drive map, and its understandable that you get low FPS
     
  8. Steel Blueflame

    Steel Blueflame
    Expand Collapse

    Joined:
    Dec 19, 2014
    Messages:
    19
    "I have on High graphics and would prefer not to change."

    sorry bud. that's the only fix. lower your settings
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice