1. Game not starting lately?
    Fixed in 0.19.4.2
    More information available here

    Dismiss Notice
  2. Intel iGPU (6xx series) crashes
    Fixed drivers available!
    Instructions here

    Dismiss Notice
  3. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    0.19 Bug Reporting thread
    Solutions and more information may already be available.

micro stutter and big stutter

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by coltonw023456, May 2, 2018.

  1. coltonw023456

    coltonw023456
    Expand Collapse

    Joined:
    Oct 26, 2016
    Messages:
    11
    so i been playing games and beam.ng drive with a ryzen 5 1600 for a bit now and every game i seem to get FPS drops and Stutter the stutter is bad but its hard to see it on video i get stutter all the time when i play micro to big stutter every thing in my case is new a month old im not sure why this is doing this i even asked tech people and EVGA and stuff they have no clue

    but i added the chart from the game beam.ng.drive and dose it look normal

    also every game i play has this issue

    System
    • CPU
      Ryzen 5 1600
    • Motherboard
      MSI B350 TOMAHAWK
    • RAM
      Patriot Viper 4 Series Extreme Performance DDR4 16GB
    • GPU
      GTX 1050 TI 4gbs
    • Case
      NZXT S340VR-Elite Matte Black/Blue
    • Storage
      SSD/HDD
    • PSU
      Corsair CX Series 550
    • Display(s)
      BenQ GW2270 21.5" 1080p LED Monitor/ SAMSUNG 32" Class FHD (1080P) LED TV
    • Cooling
      Ryzen 5 Stock cooler
    • Operating System
      Windows 10
     

    Attached Files:

    • Capture123213.png
    #1 coltonw023456, May 2, 2018
    Last edited: May 4, 2018
  2. Shingo Shoji

    Shingo Shoji
    Expand Collapse

    Joined:
    Apr 24, 2018
    Messages:
    14
    Check the temperatures. FPS drops might be a sign of thermal throttling.
     
  3. NistingurA

    NistingurA
    Expand Collapse

    Joined:
    Nov 22, 2013
    Messages:
    2,097
    I get the same problem (specs below)
    Everytime I try to record stuff or drive around a more "populated" area, my game starts "lagging"
    First thing to consider is closing all background programs, maybe set the priority for the Beam.exe to "high"
    But it might not at all solve the problem
     
  4. coltonw023456

    coltonw023456
    Expand Collapse

    Joined:
    Oct 26, 2016
    Messages:
    11
    the temps are like 50C for CPU and 40C for GPU
    --- Post updated ---
    ya i tryed that no fix it was just the same
     
  5. jojos38

    jojos38
    Expand Collapse

    Joined:
    Oct 22, 2013
    Messages:
    795
    You check the temperature when you are burning cpu and gpu ?
     
  6. coltonw023456

    coltonw023456
    Expand Collapse

    Joined:
    Oct 26, 2016
    Messages:
    11
    yes when im playing games i check
     
  7. terasect

    terasect
    Expand Collapse

    Joined:
    Mar 29, 2018
    Messages:
    110
    It looks like both of you with issues have graphics cards with pathetically low memory bandwidth for being 4gb cards.
    My old 770 4gb has twice the memory bandwidth compared to those cards and the rest of my pc is circa 2010, I have none of these problems.
    Also that graph has bumps in system memory usage that correspond with fps dips.
    I would also be curious to know if the people reporting stutters/lag like this are using onboard sound rather than a dedicated card and vice versa.

    Ideas to consider.

    Also fyi, beam already runs higher than normal priority. Part of the reason the UI lags.
     
  8. jojos38

    jojos38
    Expand Collapse

    Joined:
    Oct 22, 2013
    Messages:
    795
    Sometime, software like wallpaper engine can cause problems. You can also record the the task killer when you have lags and see if the cpu and gpu usage change strangly

    you can also try >
    Clear the cache
    Unistall the game and completly delete the folder from steamapps/common/
    Clear all your documents/beamng folder (you will lose all mods and settings !)

    Maybe it will fix the problem :c
     
  9. coltonw023456

    coltonw023456
    Expand Collapse

    Joined:
    Oct 26, 2016
    Messages:
    11
    ya i tryed that but its with every game i play
     
  10. jojos38

    jojos38
    Expand Collapse

    Joined:
    Oct 22, 2013
    Messages:
    795
    oh ok
    check if no program is using cpu or gpu when your game shutter ?
     
  11. coltonw023456

    coltonw023456
    Expand Collapse

    Joined:
    Oct 26, 2016
    Messages:
    11

    ya the game is just useing the CPU and GPU other stuff is like 0
     
  12. jojos38

    jojos38
    Expand Collapse

    Joined:
    Oct 22, 2013
    Messages:
    795
    I don't have any idea sorry :/
    Maybe reinstall windows but it's radical way and maybe it will not work
     
  13. coltonw023456

    coltonw023456
    Expand Collapse

    Joined:
    Oct 26, 2016
    Messages:
    11

    ya i did when i got my SSD last month
     
  14. Racermon

    Racermon
    Expand Collapse

    Joined:
    Jan 17, 2017
    Messages:
    129
    what graphics settings although gpu doesn't seem like the issue being that it is maintaining a low temp, although my GTX 950 runs a higher temp than your 1050Ti
    edit:
    By the graph it would be the cpu limiting it which I wouldn't understand why since it is a ryzen 1600 and it is faster than my i5 all together and I don't get the stutter
     
  15. terasect

    terasect
    Expand Collapse

    Joined:
    Mar 29, 2018
    Messages:
    110
    Look into disabling the HPET in the bios and windows 10. See if that fixes the stutters, it has for other people.
     
  16. kStor2poche

    kStor2poche
    Expand Collapse

    Joined:
    Dec 21, 2015
    Messages:
    202
    That is surely some app using suddently your cpu since I noticed that I had far but like way way way less stutters when I upgraded my cpu form a pentium g3420 to an i5 4570 while keeping the rest of my old config ( gtx760 2gb an 8gb of ram single channel ) the same... So try to disable any unwanted or useless app at startup (although be careful not to disable any system or vital task ^_^) and close every other thing that runs in background in your "hidden icons" section of the task bar and, if you still have stutters, do the same in the task manager (same here...)
     
    #16 kStor2poche, May 4, 2018
    Last edited: May 4, 2018
  17. coltonw023456

    coltonw023456
    Expand Collapse

    Joined:
    Oct 26, 2016
    Messages:
    11
    i have tryed lowest setting and max and high and normal right now it on normal
    --- Post updated ---
    --- Post updated ---
    ya i tryed i got a i5 back last year then got this ryzen 5 1600 and it got better i had this issue with the i5 as well
     
  18. terasect

    terasect
    Expand Collapse

    Joined:
    Mar 29, 2018
    Messages:
    110
    To turn off HPET through windows open a command window with administrator privileges, right click command prompt app and hit 'run as administrator'.

    To disable HPET type in/run the command;
    bcdedit /deletevalue useplatformclock

    To enable HPET type in/run the command;
    bcdedit /set useplatformclock true

    So you can turn it back on if it does not improve anything.
     
  19. coltonw023456

    coltonw023456
    Expand Collapse

    Joined:
    Oct 26, 2016
    Messages:
    11
    ya it dose nothing
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice