1. Issues with the game?
    Check the Known Issues list before reporting!

    Dismiss Notice
  2. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    0.24 Bug Reporting thread
    Solutions and more information may already be available.

Logitech G920 issue

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by Drivingislife, Jul 14, 2021.

  1. Drivingislife

    Drivingislife
    Expand Collapse

    Joined:
    Dec 11, 2019
    Messages:
    4
    I have used my Logitech G920 with BeamNG before and it has worked great. Until recently when I tried using it. Once plugged in, I press on the gas (slightly, not fully compressing it), and the car automatically red lines. I have no control of the clutch, brake, and gas pedal after that. Please help, thanks.
     
    • Like Like x 1
  2. stenyak

    stenyak
    Expand Collapse
    Global Moderator
    BeamNG Team

    Joined:
    Aug 6, 2012
    Messages:
    1,396
    Please make sure you install or update the necessary Logitech software/drivers.
    Then please make sure the in-game controls are assigned correctly. You can use the Options > Controls > Reset All button in order to remove all the modifications you have done to your controls.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice