1. Issues with the game?
    Check the Known Issues list before reporting!

    Dismiss Notice
  2. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    0.25 Bug Reporting thread
    Solutions and more information may already be available.

Gpu issue: more cars, less gpu load??? (Not bottleneck related)

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by Heraze, Jul 6, 2022.

  1. Heraze

    Heraze
    Expand Collapse

    Joined:
    Jan 8, 2020
    Messages:
    47
    Hello, I've just got a rtx 2080 and when playing solo there is no problem, game is at ultra settings, 1440p 75hz, gpu load around 70%, 75fps because Vsync. But when I spawn other cars, the gpu lowers in load, and the performance drops! I tried East Coast USA with 8 cars, traffic enabled and the gpu load was at 60% and 50 fps...
    Is that a bug? An optimisation issue?

    Also I haven't run into any issues with others games, so I'm assuming it's Beamng. No mods used while testing.

    [My specs: AMD Ryzen 3700x, RTX 2080, 16GB DDR4 @ 3000Mhz]

    Added recordings with live benchmark
     

    Attached Files:

    #1 Heraze, Jul 6, 2022
    Last edited: Jul 6, 2022
  2. Turbo49>

    Turbo49>
    Expand Collapse

    Joined:
    Apr 1, 2021
    Messages:
    2,711
    Your CPU is the bottleneck so even if the gpu would go higher it wouldn't improve the fps because your CPU is too slow.
     
  3. Heraze

    Heraze
    Expand Collapse

    Joined:
    Jan 8, 2020
    Messages:
    47
    I cleary doubt that, since a 3700x has 8 cores, 16 threads @ 3.6Ghz. I checked the cpu load with 8 cars, it was at 50%. Also I used to play with this 3700x paired to a Amd radeon 280x, and spawning 8 cars only reduced the fps by 5 to 10. The 280x was at 100% load.

    *Edit: just checked the theorical bottleneck in my build, it's about 8% and it comes from the gpu. So clearly the cpu is more than enough.
     
    #3 Heraze, Jul 6, 2022
    Last edited: Jul 6, 2022
    • Agree Agree x 1
  4. Turbo49>

    Turbo49>
    Expand Collapse

    Joined:
    Apr 1, 2021
    Messages:
    2,711
    Uh, open the performance graph using shift+control+f in-game and look at what componenet is flashing at the top of the windows that pops up, it's the bottleneck.
     
  5. Heraze

    Heraze
    Expand Collapse

    Joined:
    Jan 8, 2020
    Messages:
    47
    Here you go, so yeah the gpu is the potential bottleneck. But it is not in reality, it's just not working at its normal 99% rate...
     

    Attached Files:

    • 20220706_171702.jpg
    • Agree Agree x 1
  6. Turbo49>

    Turbo49>
    Expand Collapse

    Joined:
    Apr 1, 2021
    Messages:
    2,711
    And with traffic on ?
     
  7. Heraze

    Heraze
    Expand Collapse

    Joined:
    Jan 8, 2020
    Messages:
    47
    Check the video on my 1st message
     
  8. Turbo49>

    Turbo49>
    Expand Collapse

    Joined:
    Apr 1, 2021
    Messages:
    2,711
    That's weird, maybe try fiddling with settings such as frame limiter and v-sync ?
     
  9. Heraze

    Heraze
    Expand Collapse

    Joined:
    Jan 8, 2020
    Messages:
    47
    Doesn't impact. Still 30% cpu load, 60% gpu load, 50 fps.
    Edit: great news... now even solo it won't reach the screen limit and lowers sometimes to 70 fps at 80% gpu load.
     
  10. kbarber4545

    kbarber4545
    Expand Collapse

    Joined:
    Nov 30, 2014
    Messages:
    1

    I’m also having this problem with a 12900ks and a 3090ti
    --- Post updated ---
    Must be a problem with the game with the new update
     
  11. SativaPancake

    SativaPancake
    Expand Collapse

    Joined:
    Jan 11, 2022
    Messages:
    3
    1
     
    #11 SativaPancake, Jul 10, 2022
    Last edited: Jul 12, 2022
  12. Fluffy Panda

    Fluffy Panda
    Expand Collapse
    Global Moderator
    BeamNG Team

    Joined:
    Sep 16, 2020
    Messages:
    805
    Try to set your graphic settings to High and compare your game performance
     
  13. default0.0player

    default0.0player
    Expand Collapse

    Joined:
    Nov 30, 2018
    Messages:
    1,729
    [redacted, sounds too critical, didn't mean it, sorry] I have several cars spawned the FPS goes down, which is pretty natural at first glance, until you watch the GPU usage % and pause the game. When paused, the GPU usage goes straight up to 96% and the FPS goes up, when unpaused, the GPU usage goes down dramatically to 37% to 48%
     
    #13 default0.0player, Jul 20, 2022
    Last edited: Jul 20, 2022
  14. Turbo49>

    Turbo49>
    Expand Collapse

    Joined:
    Apr 1, 2021
    Messages:
    2,711
    I think you forgot it's in early access, what do you expect from a physics model that no one has ever made before (apart from RoR, which runs better, but it doesn't have as much features simulated) running on a decade old graphics engine, all that made by a fairly small team ?
     
  15. Heraze

    Heraze
    Expand Collapse

    Joined:
    Jan 8, 2020
    Messages:
    47
    I tried, same performance, no difference. Hitting the cap at 75 fps when solo; getting 50 fps, 60% gpu load when adding 7 traffic cars.
     

    Attached Files:

    • Eastcoast7trafficcarshighsettings.png
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice