1. Issues with the game?
    Check the Known Issues list before reporting!

    Dismiss Notice
  2. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    0.25 Bug Reporting thread
    Solutions and more information may already be available.

game lags like hell randomly

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by TPWTB TV, Jan 27, 2022.

  1. TPWTB TV

    TPWTB TV
    Expand Collapse
    Banned

    Joined:
    May 21, 2021
    Messages:
    499
    So I recently got a new computer and when I spawned more then 20 cars, the games lags like hell until it eventyally crashes. At first I thought it was just something wrong with my computer, but then somebody told me that most people have it... And Im currently working on a beamng movie and the final scene will involve alot of cars... So devs, if you are reading this, please fix this as soon as possible... Thank you
     
    • Agree Agree x 1
  2. TheSomething

    TheSomething
    Expand Collapse
    Banned

    Joined:
    Oct 16, 2021
    Messages:
    1,056
    Maybe the map where you spawn it takes many RAM?
     
  3. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    6,799
    Bruh stop. I think it's kinda obvious that just spawning a lot of cars by themselves even on an empty map causes lag. It has always been the case and will never change, because that's how computers work, the more calculations they have to do, the more laggy they get. Recording in slow motion is the only known workaround to this.
     
    • Agree Agree x 1
  4. TPWTB TV

    TPWTB TV
    Expand Collapse
    Banned

    Joined:
    May 21, 2021
    Messages:
    499
    But the thing is, it's too laggy to record in slow mo. Even frizeris has it.. Hopefully it will be fixed in next hotfix.
     
    • Agree Agree x 1
  5. Car_Killer

    Car_Killer
    Expand Collapse
    QA / Mod Support
    BeamNG Team

    Joined:
    Sep 24, 2013
    Messages:
    1,375
    What are your PC specs?
    Also, check that guide to improve performance. Looks like your PC is too slow to handle 20 vehicles, in that case, the best way is to disable collisions to get a higher frame rate.
    To run 20 vehicles smoothly in real-time in most cases you need at least Ryzen 9 5900X. Think of it as basically, 1 vehicle needs 1 thread to run the game smoothly. If you have 6 thread CPU, you most likely won't be able to run more than 6 vehicles, unless you use slow motion or disable collisions.
     
  6. JackDrift

    JackDrift
    Expand Collapse

    Joined:
    Oct 31, 2020
    Messages:
    34
    i dont personally have this issue but my friends with similar pcs randomly have this issue, they will be playing normally with 2 or 3 cars and suddenly drops down to like 10 to 15 fps from 80/90? this also happens frequently on beamMP too for my mates
     
  7. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    6,799
    BeamMP has its own problems that could be unrelated to the base game.
     
  8. Kirby_49

    Kirby_49
    Expand Collapse

    Joined:
    Jun 9, 2018
    Messages:
    191
    bruh
    > spawns 20 cars
    >game lags randomly
     
  9. ghs129

    ghs129
    Expand Collapse

    Joined:
    Jul 3, 2021
    Messages:
    513
    I dont think its just 20, for me, sometimes i can spawn 14 just fine and sometimes it crashes on 3!
     
  10. Olrosse

    Olrosse
    Expand Collapse

    Joined:
    Jan 21, 2013
    Messages:
    105
    Sounds like the SFX issue, seems to happen quicker the more cars there is, which is why it's so common in multiplayer, it also seems consistent, the other day we had 9 people in one server all join and spawn at nearly the exact same time, and the SFX bug happened to all of us at nearly the same time, like within the same minute
     
  11. TPWTB TV

    TPWTB TV
    Expand Collapse
    Banned

    Joined:
    May 21, 2021
    Messages:
    499
    Its nothing to do with my pc my pc would be a beast if is wernt for this glitch. It works perfectly for about 5-10 minutes and then the crashing sound dissapers and then the game starts lagging like hell until it eventually crashes. Apparently alot of people have this glitch and it came in the latest hotfix. Its knowen as the ram leak I think so its nothing to do with my pc performance
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice