1. Issues with the game?
    Check the Known Issues list before reporting!

    Dismiss Notice
  2. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    0.25 Bug Reporting thread
    Solutions and more information may already be available.

Forest editor crash on object placement

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by bob.blunderton, Jun 15, 2018.

  1. bob.blunderton

    bob.blunderton
    Expand Collapse

    Joined:
    Apr 3, 2015
    Messages:
    3,053
    !@#$%!!!!

    This bug has been around since 0.9.x, since the forest editor was re-done.
    Cannot place any object - or randomly some objects - without a CTD.
    Doesn't matter if there's a bunch used already, or if you do other things first.
    Doesn't matter how many objects are in the map. This happens a LOT.

    To the point I can no-longer place anything in the map, and for now am considering shelving my city map permanently until the bug is fixed (because, I can't place anything).

    This bug first reared it's head in Roane County Tennessee development, but I was always able to get around it after trying to move another forest object around (there-by accessing the files that store them and having them ready), now I cannot. Maybe it's shared privileges this game does not like, as some may be open in a text editor (because the stupid forest brush FAILS to delete most anything I try to delete!!!).
    It's very hard to get a nice map made when nothing is working in the forest brush.

    Can't upload the log it's 71mb. I don't know how a log gets to 71mb but whatever.

    The game doesn't give a specific error anyways, so take a piece of blank paper and pretend it's the log.
    What's the log supposed to do anyways? It's been next to useless for editor-related errors since 0.10 or 0.11
     
  2. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    6,784
    How about if you rename/remove texture of said object that you try to replace, so that game does not find the texture, does it crash or place beautifully orange object with words on it?

    What I have had happen with editor was that when I did click to place an object, I got instantly a crash, but with texture removed it placed object just fine. Path of the object was perfectly right, except it did reside inside a zip file of JRI, it should of worked, it should work from the path despite being in zip, but no, only did work when I removed texture file.

    If your crash disappears by removing texture, then it would reveal that this crash is by the game somehow messing up it's own paths in memory or some other place, but at least it would give place in code to examine closer.

    However it could be that there is some other part of code that causes crash in your case, either way testing with renaming texture file would be easy to do.

    Just thought that came to me all of sudden.
     
  3. Nadeox1

    Nadeox1
    Expand Collapse
    Spinning Cube
    BeamNG Team

    Joined:
    Aug 5, 2012
    Messages:
    14,657
    I feel you, the editor can be a pain when you encounter such issue as you see.
    We are working on stabilizing it, but it will be a bit before you can start seeing that yourself.

    Your maps are particularly big, and thus are pretty specific cases where the game engine and editor are literally being pushed to their limits.
    Please understand that very weird things can happen when you use them in ways they were not meant to be. There's not much to do about these sometimes.

    The crash when you add an object:
    The object is a forest element?
    You tried on an empty map? ( to see if it's a problem with the object itself, or related to the level )
    The same happens if you add the object as a normal static object?
     
    • Informative Informative x 1
  4. tdev

    tdev
    Expand Collapse
    Developer
    BeamNG Team

    Joined:
    Aug 3, 2012
    Messages:
    2,977
    Crash report pls?
     
    • Informative Informative x 1
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice