WIP Beta released ETK800 Hybrid 8.0.1

Full hybrid versions of the ETK800 hatchback car

  1. Milendur

    Milendur
    Expand Collapse

    Joined:
    Apr 26, 2021
    Messages:
    317
    • Like Like x 1
  2. SKB

    SKB
    Expand Collapse

    Joined:
    Apr 22, 2017
    Messages:
    1,962
    diesel hybrid is kinda possible (i put the diesel stuff in and it works,) but there's no Diesel Hybrid Gauges yet
     
  3. Milendur

    Milendur
    Expand Collapse

    Joined:
    Apr 26, 2021
    Messages:
    317
    Not having diesel gauges is a pain, author is american i think so everything is made with their standards
     
    • Agree Agree x 1
  4. spencerm25251

    spencerm25251
    Expand Collapse

    Joined:
    Feb 23, 2019
    Messages:
    80
    new default config: facelifted ETK 800 Sedan with an i6 diesel, all-wheel steering, openable doors and driver assistance features...

    now with the addition of hybrid components!
     

    Attached Files:

    • screenshot_2021-11-08_15-48-06.png
    • screenshot_2021-11-08_16-05-33.png
    #344 spencerm25251, Nov 8, 2021
    Last edited: Nov 8, 2021
    • Like Like x 4
  5. Arcanox

    Arcanox
    Expand Collapse

    Joined:
    Aug 22, 2018
    Messages:
    278
    I think I know what you're describing, I call it "mode 1" driving (it's used at higher speeds when MG1 is spinning backwards, and thus can't provide generator drag). It is modeled, and it's used in that situation I just mentioned where the combination of engine RPM and vehicle speed lead to MG1 rotating backwards. The ETK will use the battery for a certain "ratio" of the driver's requested torque, depending on how charged the battery is. I changed the way this works a little bit in the 8.0 update (technically the 5.0 update of the Core mod); if you've taken your foot all the way off the throttle and then lightly applied it, it's more inclined to use battery power (even if the engine is on, like on the highway). However, if you start accelerating enough to where the engine "kicks in" and starts working, then it will prioritize the engine for torque until you start to coast again. If the battery is somewhat low while doing this, it'll also charge the battery slowly while the engine is providing torque. And, of course, if the battery is SUPER low, it will not provide any torque from the battery at all, and will always try to recharge the battery while the engine is under load until it gets above a certain threshold.

    This seems to be closer to how my RAV4 Prime operates in hybrid mode, but it's tough to tell how much it's actually trying to draw from the battery since it doesn't have a very high resolution indicator of state-of-charge. It's tricky to get all the curves right that this logic depends on...I'm sure I could tune it a bit better so the battery level stays more consistent at consistent speeds.
    --- Post updated ---
    Make sure you don't have any other mods installed that provide bindings for the ETK800, or the game may overwrite mine with those (depending on the order in which it loads the mods). Also make sure you don't have any rogue input/settings files in your BeamNG User Folder that might be providing bad bindings somewhere.
     
  6. DamienDutch

    DamienDutch
    Expand Collapse

    Joined:
    Feb 9, 2016
    Messages:
    97
    I reinstalled it via repo now it works perfect.
     
  7. cartruck4

    cartruck4
    Expand Collapse

    Joined:
    Dec 16, 2016
    Messages:
    3
    Since you said you have a Rav4 Prime is there any chance there will be a Tograc hybrid in the future?
     
  8. Arcanox

    Arcanox
    Expand Collapse

    Joined:
    Aug 22, 2018
    Messages:
    278
    Perhaps! Depends on how much time I have to work on it; I'm juggling my time between a lot of projects right now, so it really depends on what I feel like working on and when.
     
  9. Xupaun

    Xupaun
    Expand Collapse

    Joined:
    Aug 18, 2020
    Messages:
    527
    I have to say that the behaviour of this system fits way better the Vivace/Tograc than the ETK 800. Specially when you think about acceleration. Maybe I'm too familiar with the punch of EVs, but I find its acceleration kind of sluggish. Maybe if it got a first gear it would be better, since any geared version (DCT or AT), have a stronger acceleration off the line. Also, it should have a speed limiter in reverse.
    Long story short, the way this system behaves is way more fitting to a FF compact car like the Vivace or the Sunburst, than it is to a larger FR wagon.
     
    • Agree Agree x 3
  10. DoritoPowahhhh

    DoritoPowahhhh
    Expand Collapse

    Joined:
    Jan 17, 2021
    Messages:
    190
    dang thats my idea i said it on a discord server now its getting WAY TOO POPULAR, my child is growing strong!
     
  11. 98crownvic

    98crownvic
    Expand Collapse

    Joined:
    Jul 14, 2016
    Messages:
    1,523
    I agree. I love this mod, but I think my Toyota hybrid is faster than the ETK is.

    Edit: I realized that all of my driving I had done prior to writing this was with the eco hybrid. The sport hybrid has a lot more kick to it.
     
    #351 98crownvic, Nov 10, 2021
    Last edited: Nov 10, 2021
  12. ARES IV

    ARES IV
    Expand Collapse

    Joined:
    May 6, 2019
    Messages:
    362
    Thank you for updating this great mod. Sadly it seems to be quite buggy for me:
    (Video ist not listed)



    - Arcanox Debug App never ever shows any information.
    - It often causes the rest of the UI apps to glitch out (and be hidden) See missing tacho and no damage app reaction even when damaging the car.
    - I loose all input on the car when that happens. I cannot steer, accelerate or brake the hybrid. It is basically disconnected from all input.Even pressing the key for engine start does nothing at all.
    - Spawning with the hybrid does not help.
    - The ETK 800 Hybrid is the worst affected. The bus works somewhat better.


    Things I have tried:

    - Unsubscribing and subscribing again
    - Safe mode (and subscribing to the mod in it again)
    - All other mods disabled
    - Verified game on steam
    - Verified game files with deep cache clearing
    - Computer restart
    - Deletion of the entire userfolder

    And I cant fix it. Maybe you have an idea what goes wrong for me?
     
  13. alentaylor22

    alentaylor22
    Expand Collapse

    Joined:
    Jan 19, 2018
    Messages:
    438
    Don’t download it from the repo get it from the forum that’s how it worked for me
     
  14. Arcanox

    Arcanox
    Expand Collapse

    Joined:
    Aug 22, 2018
    Messages:
    278
    All I can tell from the video is that something is causing errors in the UI code and/or the game's Lua code. If you're able to upload your beamng.log file in the user folder after you've tried to use the Hybrid vehicles, I might be able to help, but aside from that I have no idea what would cause that. It sounds like you have a corrupted game or other corrupted mods, or some other program that's breaking them (antivirus or something).

    I haven't uploaded a version of any of the hybrid mods to the forum in a very very very long time, if ever; it would be an absolutely ancient version. I can't honestly remember if I have uploaded a version of it anywhere but the repo.
     
    • Like Like x 1
  15. Xupaun

    Xupaun
    Expand Collapse

    Joined:
    Aug 18, 2020
    Messages:
    527
    Well I tried the performance eCVT. Even though it catches up with the non Hybrid (making it actually faster on the quarter mile), the takeoff is really slow. I spected that the EV mode was gonna be nice, but again, same problem, lots of power but only after some speed. Considering how it behaves on launch control (the ICE kind of revs alone for one or two seconds while the car accelerates on a slow "electric" pace), it could have that electric punch that even the Vivace E has on the take off, and then the ICE catches up giving extra power. Oh, that's happens with ESC & TTC OFF.
     
  16. alentaylor22

    alentaylor22
    Expand Collapse

    Joined:
    Jan 19, 2018
    Messages:
    438
    8D1322A7-AAAD-4560-B2AD-D13EF9A073C1.jpeg
    I mean like this one the one in game doesn’t work for me atleast
     
  17. Arcanox

    Arcanox
    Expand Collapse

    Joined:
    Aug 22, 2018
    Messages:
    278
    I'm not sure why that would be happening with TCS off, usually that's due to TCS limiting the throttle. I'll do some investigation to make sure I didn't somehow regress the punchiness of EV mode, but when I was testing out the performance version before I released 8.0, I could easily spin the tires with TCS off and the car stopped.
    --- Post updated ---
    How doesn't it work? Can you share your log file somehow? I always test my mods as they will be uploaded to the repo (packed up, with nothing else installed in my game) before I release a new version, and the moderators test them as well. I'd need logs to have an idea why it wouldn't be working for someone.
     
  18. alentaylor22

    alentaylor22
    Expand Collapse

    Joined:
    Jan 19, 2018
    Messages:
    438
    Noo it works for me I was trying to help the other dude cuz when I first downloaded the mod I used the in game repo(the one in beam ng) and it was glitchy but then I deleted it and downloaded it from here the website repo ig I just call it the forums and it works
     
  19. default0.0player

    default0.0player
    Expand Collapse

    Joined:
    Nov 30, 2018
    Messages:
    1,443
    Found some minor problems
    1. In the Race Hybrid, the rear motor is the same as Sport Hybrid, making it very understeery.
    2. The ESC drive mode. When the throttle is at the same, let's say 25%, switching to Sport makes the engine rev up, switching to ESC-OFF then engine revs down to the same as Comfort.
     
  20. Xupaun

    Xupaun
    Expand Collapse

    Joined:
    Aug 18, 2020
    Messages:
    527
    That's what I found strange. The electric motor on the performace eCVT is quite powerful (somewhere around 400 whp, according to the engine debug app). The strange thing is that it doesn't take off like a 400ish hp electric car does. I found it struggling to climb some hills that the same car, with a standard automatic transmission, or even the DCT, climbs easily. Even on EV mode, it feels like the electric power has to go through the CVT, instead of going directly to the wheels (specially the rear ones).

    I understand that. I meant to say that it feels CVTish.
    Also, did some drag race between the Race Hybrid and a non hybrid version of it (simply replaced the eCVT with the 8 speed DCT, the diffs with the standard e-Locking, added the AWD transfercase, and everything else to "remove any trace on the hybrid", but keeping the same ICE and final drive ratios, both corrected to be 3.91 front and back). The results were what I said before. The non Hybrid is faster right of the bat (even broke the tires loose for a second) but the Hybrid quickly catches up and easilly pass (it doest have to shift and it makes, at least, 200 more horsepower).

    When driving the hybrid, against the AI with the non hybrid, I could launch faster some times, but when the electric power really kicks in, the non hybrid loses miserably.

    Maybe the right analogy is: The non hybrid launches like a car with a small turbo and almost no turbo lag, while the Hybrid behaves lke the same car with a gigantic turbo with great turbo lag.
     
    #360 Xupaun, Nov 10, 2021
    Last edited: Nov 10, 2021
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice