Beamng playing at 30 fps with settings set to 60hz

Discussion in 'General Discussion' started by Chance Barber, Feb 28, 2020.

  1. Chance Barber

    Chance Barber
    Expand Collapse

    Joined:
    Nov 9, 2017
    Messages:
    38
    I have an Alienware 15 r4 and I hooked the hdmi to my 4k tv with a 60hz refresh rate, yes I changed my display options on the computer to suit the tv specs, and i have the games resolution settings matching the tv specs. Whatever the 4k resolution is at 60hz but I play beam, and it's only playing at 30fps. Anyone know how to fix this?
     
  2. ajz177

    ajz177
    Expand Collapse

    Joined:
    Jun 28, 2016
    Messages:
    103
    There should be an option in settings to change your frame rate limit.
     
  3. crashmaster

    crashmaster
    Expand Collapse

    Joined:
    Aug 4, 2013
    Messages:
    1,622
    It depends.
    If it sometimes manage to hit above 30 fps, like 31/32 and above it just means the laptop isnt powerfull enough to run the game in 4k at 60fps.

    If all of the frame limitting options in the settings are disabled. Im gonna go with not powerful enough for 4k.
    Whats the specs?
     
  4. Four of Clubs

    Four of Clubs
    Expand Collapse

    Joined:
    May 19, 2019
    Messages:
    23
    An Alienware 15 R4 huh? I'm assuming your specs are:
    • 8th Generation Intel Core i7-8750H (6-Core, 9MB Cache, up to 4.1GHz w/ Turbo Boost)
    • 15.6 inch FHD (1920 x 1080) 60Hz IPS Display | NVIDIA GeForce GTX 1060 OC with 6GB GDDR5
    • 16GB (2x8GB) 2400MHz DDR4 Memory
    • 128GB PCIe Solid State Drive + 1 TB 2.5-Inch SATA Hard Drive (7200 RPM)
    If so your lucky to get 30 fps at 4K since your using a GTX 1060. Vsync is probably keeping you locked at 30fps if you have that enabled.
    Try lowering your resolution. 1440p is probably the absolute limit of your gpu, and 1080p is the sweet spot.
     
    • Agree Agree x 1
  5. Sithhy™

    Sithhy™
    Expand Collapse

    Joined:
    Apr 5, 2017
    Messages:
    2,863
    Does your TV have a game mode? If yes, then set it to that, as I think your PC is reading the max refresh rate of the TV in the standard mode (which is 30Hz) & thus vsync ingame limits you to 30fps no matter what you do. When you're done with that, go into the settings ingame, disable vsync & set the game to borderless window, so that way you will be able to push as many fps as your GPU can do
     
    • Agree Agree x 1
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice