1. Stuck or having problems creating your mod?

Solved Automation car pack, packed correctly?

Discussion in 'Mod Support' started by FluffyOreoCX, Jul 16, 2018.

  1. FluffyOreoCX

    FluffyOreoCX
    Expand Collapse

    Joined:
    Jan 31, 2016
    Messages:
    1,888
    I'm trying to make a car pack for my Automation cars... did I do this correctly? Please guide me in the correct direction ;-;

    (I put only one vehicle in there for a test)​
     

    Attached Files:

  2. torsion

    torsion
    Expand Collapse

    Joined:
    May 31, 2015
    Messages:
    1,585
    No, you did not. The zip from Automation is packed correctly. Putting that inside another zip file is incorrect.

    Your structure should be:
    pack.zip/stuff
    but you've got:
    pack.zip/vehicle.zip/stuff

    Where "stuff" consists of directories such as "vehicles" & "art".

    Try using the in-game mods manager to unpack a couple of your Automation zips. You'll see that they unpack to:
    Documents\BeamNG.drive\mods\unpacked\here_is_my_first_mod\
    Documents\BeamNG.drive\mods\unpacked\here_is_my_second_mod\
    etc

    At that point close the game, rename a mod folder to represent the pack, and put the contents of the other folders into the pack folder. Launch the game and it will see that folder in the mods manager and give you the opportunity to pack it.
     
  3. FluffyOreoCX

    FluffyOreoCX
    Expand Collapse

    Joined:
    Jan 31, 2016
    Messages:
    1,888
    Thank you very much!
     
    • Like Like x 1
  4. Inn0centJok3r

    Inn0centJok3r
    Expand Collapse

    Joined:
    Jul 16, 2018
    Messages:
    287
    Ive tried it too... ive packed the unpacked cars into a folder but the cars dont show up in the game...i must have done something wrong...but what?
    And i cant upload the zip file for whatever reason. Im waiting 15 mins for it to upload 215mb...and it still doesnt do anything. When i go to `upload fileĀ“ it actually does something and when it done i can only close the window and then its gone...
     
    #4 Inn0centJok3r, Aug 14, 2018
    Last edited: Aug 14, 2018
  5. torsion

    torsion
    Expand Collapse

    Joined:
    May 31, 2015
    Messages:
    1,585
    It's OK to have your own thread about this issue! I posted that link as a reference material, not to scold you for having your own thread.

    Anyway we can discuss it here too unless FluffyOreoCX minds, it's all good.
    1. Does the mod show up in the mod manager?
    2. Check your console for errors when you load the game. Use "~" on your keyboard.
    3. If you don't see any relevant errors at the home screen then load up a map and go to the vehicle selector and then check for errors again.
    4. Make a smaller pack and test that. 2 cars only. It'll be easier to upload if it doesn't work.
     
  6. Inn0centJok3r

    Inn0centJok3r
    Expand Collapse

    Joined:
    Jul 16, 2018
    Messages:
    287
    Oh i didnt interpret it as sholding me... i just figured it would be better to just reply here...anyway, the pack shows up in the mod menu and when i loaded gridmap the first time, there were a ton of errors but none of them related to my 'ultimate car pack'
    However when i closed the game and launched it again there were still no errors related to the mod and when i then loaded the empty grid map there werent any errors exept the ones before.
    20180814200815_1.jpg
    20180814200829_1.jpg
    The errors when i loaded gridmap.
    I havent yet tried a smaller pack so thats what ill do now
    --- Post updated ---
    Ive tested a smaller pack with 2 cars, I unpacked the cars, threw them into a new folder, put the folder into the unpacked folder, packed it in beamng and it doesnt work. Heres the zip folder with the 2 cars in it (it shows up in the manager too)
     

    Attached Files:

  7. torsion

    torsion
    Expand Collapse

    Joined:
    May 31, 2015
    Messages:
    1,585
    1. Please disable all mods except the one you are working on.
    2. Please read post #2 in this thread.
     
  8. Inn0centJok3r

    Inn0centJok3r
    Expand Collapse

    Joined:
    Jul 16, 2018
    Messages:
    287
    Ive tested a smaller pack with 2 cars, I unpacked the cars, threw them into a new folder, put the folder into the unpacked folder, packed it in beamng and it doesnt work. Heres the zip folder with the 2 cars in it
    Alright ive just thrown the contents of the car folders in the pack an it works! Thanks for guiding me on how to do that! You might see a 12 car mod pack soon on the automation repository! (with many more cars to come)
     
    • Like Like x 1
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice